Yunzai-Bot v3

云崽v3.0,原神qq群机器人,通过米游社接口,查询原神游戏信息,快速生成图片返回,2.0版本作者已经不维护啦。

准备环境

Windows or Linux,Node.js(版本至少v16以上Redis

部署方式

  1. 宝塔安装所需环境,在控制台执行命令安装。
  2. 使用docker安装,目前云崽已经支持docker安装。(推荐)

宝塔安装环境部署

首先我们要安装宝塔,宝塔的安装就不一一说明啦,贴出官方安装文档。

安装环境

安装pm2管理器,内置很多依赖。不用频繁安装依赖。

安装node环境

pm2

安装redis

这个是云崽运行必须的,否则云崽会直接报错redis连接失败。

安装redis

git克隆云崽

  1. github
    git clone –depth=1 -b main https://github.com/Le-niao/Yunzai-Bot.git
  2. gitee
    git clone –depth=1 -b main https://gitee.com/Le-niao/Yunzai-Bot.git

git拉取

cd Yunzai-Bot #进入Yunzai目录

安装pnpm,已安装的可以跳过
npm install pnpm -g

安装pnpm

安装依赖
pnpm install -P

安装依赖

运行(首次运行按提示输入登录)
node app

登陆

docker部署

安装docker,我这里使用宝塔安装docker,比较方便不用执行命令安装。
安装docker

拉取镜像

docker 镜像支持 v2 和 v3 的部署,每个版本镜像分为 精简版 和 扩展版,精简版仅有云崽本体(可选加载喵喵插件和图鉴插件),扩展版附带 ffmpeg 环境和 Python 环境(可选加载 Python 插件)。
精简版

sirly/yunzai-bot:v3

扩展版

sirly/yunzai-bot:v3plus

拉取镜像

创建容器

云崽不需要特殊端口或者环境变量,直接创建就可以使用。
创建容器
打开容器终端执行node app就可以运行机器人。根据提示登陆即可。
打开终端
登录

云崽插件列表

https://gitee.com/yhArcadia/Yunzai-Bot-plugins-index
推荐安装

常见问题

显示qq版本过低

由于风控原因登录会显示qq版本过低,在/root/Yunzai-Bot/data/qq账号/device-qq账号.json在里面修改imei,建议在手机拨号哪里输入*#06#使用自己的手机imei这样可以更稳定登录。记住填写手机上面那个imei1

运行显示报错

建议检查依赖,docker一般不会出现这个问题。